Rear Shock Top Mounting – clunking

Everthing you wanted to know about getting the perfect suspension & handling, Springs, Shocks, Roll Bars, Coilovers, Brakes, Steering for your RX7...
User avatar
Casey
Posts: 449
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Rear Shock Top Mounting – clunking

Post by Casey » Mon Sep 05, 2016 4:27 pm

Driving back from The Retro Rides Gathering recently, a “clunking” developed, which appeared to be coming from the rear nearside. It only occurred on bad road surfaces, no problem on a smooth road. I stopped the car and did a quick check that nothing was obviously loose or broken (I couldn't see/feel anything) and drove carefully home for the last 30 miles.

I've had the chance to take a better look today and I'm 95% sure it's the rod in the rear n/s shock rod that is banging against the side of the top mounting hole (diagram from Haynes manual):

Image


The grommet shown in the diagram has all but disintegrated (light brown item in pic below), so allowing some sideways movement:

Image

The shock itself, although manky, still appears OK, albeit the bottom bush is showing some signs of age. I’m torn between cleaning it up, sorting out the “grommet” and putting it back on. I’m thinking I might put an “O” ring or two in place of the grommet?

Alternatively, I have a pair of brand new KYB shocks that are meant for KIMI 1, so reluctant to use those in case I have trouble sourcing another pair. Also, here is a picture of the KYB shock and fixings, but it doesn’t include a grommet either?

Image

Has anyone got any thoughts before I put things back together?
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
MelloYello
Posts: 1090
Joined: Wed Jun 01, 2011 8:42 pm
Location: London, England.

Re: Rear Shock Top Mounting – clunking

Post by MelloYello » Mon Sep 05, 2016 5:28 pm

I am sure some generic replacement from eBay would do the trick.

User avatar
DKWW2000
Posts: 1210
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: Rear Shock Top Mounting – clunking

Post by DKWW2000 » Mon Sep 05, 2016 5:33 pm

I changed mine about a year ago with new KYB, I seem to recall my new rubber bushes were similar to the drop link bushes & had a thin lip on one surface which I fitted against the chassis.
I have some old Drop link bushes I could send if you needed them as they are similar?

I used them cut down when I fitted the Front Strut inserts as they rattled in the strut & I also used some thick 'O' rings
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

Boggy2112
Posts: 71
Joined: Wed Jul 06, 2016 7:03 pm

Re: Rear Shock Top Mounting – clunking

Post by Boggy2112 » Tue Sep 06, 2016 10:04 pm

I have just striped a old fb, i am sure i have the rubbers if you need them!

TOOL
Posts: 2513
Joined: Thu Sep 01, 2011 10:30 am
Location: Var, France (ex NZ, ex UK)

Re: Rear Shock Top Mounting – clunking

Post by TOOL » Wed Sep 07, 2016 5:41 am

See if you can get a generic grommet, like the ones on the firewall stopping the loom getting cut. That should go it.

Never seen grommets used on shocks before.
Back in sunny France

User avatar
kenwhiteside
Posts: 166
Joined: Sat May 26, 2012 7:03 pm
Location: Hove

Re: Rear Shock Top Mounting – clunking

Post by kenwhiteside » Wed Sep 07, 2016 9:08 pm

I got a pair of those shocks for just over 20usd from rock auto a few weeks ago. Have a look there.

User avatar
Casey
Posts: 449
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: Rear Shock Top Mounting – clunking

Post by Casey » Mon Sep 12, 2016 9:09 pm

Thanks for the replies guys. I looked around in my spares bin and found some rubber parts that are perfect to replace the grommets! The shocks look in good shape, no leaks, and they appear to work fine, so I've now taken both shocks off KIMI 2 (and yes, the grommet in the 2nd shock was also in bad shape, no surprise there!).

I've now degreased both shocks, metal prepped them and put on 2 coats of Black POR15. I've left them to cure/dry overnight and will hopefully get them back on the car tomorrow. I'll post up some pics in my KIMI 2 thread later for the record :D

BTW, does anyone know the difference between these two KYB rear shock types:

KYB 343140
KYB 343064

I have a pair of the latter ready to go onto KIMI 1, but the 343140 is showing as the p/n on RockAuto for the 1979-85 RX-7?
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

KiwiDave
Posts: 1789
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: Rear Shock Top Mounting – clunking

Post by KiwiDave » Tue Sep 13, 2016 2:37 am

Casey wrote:BTW, does anyone know the difference between these two KYB rear shock types:

KYB 343140
KYB 343064

I have a pair of the latter ready to go onto KIMI 1, but the 343140 is showing as the p/n on RockAuto for the 1979-85 RX-7?
Both part numbers appear to refer back to the ExcelG. For the US market, KYB dropped the ExcelG label and reintroduced them as GR2. The rear shocks were the same fitment '79 thru '85 whereas the fronts differed. Series One fitment was unique (taller). S2/S3 were the same.
1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

User avatar
Casey
Posts: 449
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: Rear Shock Top Mounting – clunking

Post by Casey » Tue Sep 13, 2016 3:15 pm

Thanks Dave - they appear to be physically identical to the S2 shock I removed, so hopefully OK when I come to fit them to KIMI 1 :)
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
Casey
Posts: 449
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: Rear Shock Top Mounting – clunking

Post by Casey » Tue Sep 13, 2016 7:47 pm

Shocks immediately after removal, covered in grease by the previous owner, in an attempt to ward off tin worm...

Image

Degreased, ready for acid etch and POR15...
Image

2 coats of POR15, a little better...
Image

Fitted, the cleanest bit under there!
Image

These are the two "washers/grommets" I made from a rubber cap I had lying around...
Image

Fitted into the gap a treat - a tight fit over the damper rod too...
Image

The bad news is, I still have the clunking sound :oops: - more diagnosis required....
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

Post Reply