Engine goes lean while accelerating under half throttle

Rotary Engine Chat......Got A Problem With Your Rotary Engine.... Need Help...?
Rubarotary
Posts: 30
Joined: Thu Jul 14, 2016 11:20 pm

Re: Engine goes lean while accelerating under half throttle

Post by Rubarotary » Sun Aug 21, 2016 1:59 am

I can't seem to understand how the carb works , i checked Flow between the ports And they were almost identical so No problegm there but i tried a different carb And then the problem is solved so there has to be something wrong. :-s

Correct me if i'm wrong but the More Flow passes by the venturis the more fuel Will Flow so how can it Be that the Flow is the Same in Both primary holes but one gets No fuel out of the primary Jet And the other one Does ?
There's nothing to shut the fuel to the Jets right ? Only place were the fuel is shut off is in the float Chambers And only because otherwise the fuelpump would Just pump the engine full of fuel.

Is there any place i can find a detailed description on how this carb works ?

Again thank you For All the Help so far.

User avatar
spirit r
Posts: 1350
Joined: Sat Feb 09, 2013 4:15 pm
Location: Germany Black Forest
Contact:

Re: Engine goes lean while accelerating under half throttle

Post by spirit r » Sun Aug 21, 2016 8:22 am

Rubarotary wrote:Is there any place i can find a detailed description on how this carb works ?

Again thank you For All the Help so far.

http://www.rx7fb.com/viewtopic.php?f=30&t=131

https://dl.dropboxusercontent.com/u/737 ... Manual.pdf

TOOL
Posts: 2513
Joined: Thu Sep 01, 2011 10:30 am
Location: Var, France (ex NZ, ex UK)

Re: Engine goes lean while accelerating under half throttle

Post by TOOL » Sun Aug 21, 2016 8:57 am

If the bowl is filling, then you've got a blockage in the primary circuit.
Back in sunny France

Rubarotary
Posts: 30
Joined: Thu Jul 14, 2016 11:20 pm

Re: Engine goes lean while accelerating under half throttle

Post by Rubarotary » Sun Aug 21, 2016 12:55 pm

Bowl is filling And i blew through the primary circuit And Air Comes through so i don't understand but i'll try some More maybe Jets from another carb

TOOL
Posts: 2513
Joined: Thu Sep 01, 2011 10:30 am
Location: Var, France (ex NZ, ex UK)

Re: Engine goes lean while accelerating under half throttle

Post by TOOL » Sun Aug 21, 2016 6:45 pm

You got the jets at the bottom of the bowls, right?
Back in sunny France

Rubarotary
Posts: 30
Joined: Thu Jul 14, 2016 11:20 pm

Re: Engine goes lean while accelerating under half throttle

Post by Rubarotary » Sun Aug 21, 2016 9:29 pm

The Jets inside the bowls are different sizes ? Because i replaced them with Jets from another carb so i might Have taken the main one from a secondary :-s

Rubarotary
Posts: 30
Joined: Thu Jul 14, 2016 11:20 pm

Re: Engine goes lean while accelerating under half throttle

Post by Rubarotary » Sun Aug 21, 2016 9:33 pm

Oh And thank you Spirit r For the links ,it's been a great Help For me. Now i understand a little better how it works :-D

Rubarotary
Posts: 30
Joined: Thu Jul 14, 2016 11:20 pm

Re: Engine goes lean while accelerating under half throttle

Post by Rubarotary » Mon Aug 22, 2016 8:44 pm

TOOL you were Right i replaced a primary main Jet with a secondary one :-o thanks a lot For All the Help, i adjusted the carb a little afterwards And it's Running great now :-D

User avatar
A7RXY
Posts: 1123
Joined: Fri Apr 01, 2011 6:55 am
Location: Upminster, Essex UK

Re: Engine goes lean while accelerating under half throttle

Post by A7RXY » Mon Aug 22, 2016 8:51 pm

Well done Andrew (Tool) for showing why this forum is so helpful.

Dibs

codge
Posts: 2602
Joined: Fri Apr 01, 2011 11:41 am
Location: South Yorks.

Re: Engine goes lean while accelerating under half throttle

Post by codge » Tue Aug 23, 2016 11:20 am

A7RXY wrote:Well done Andrew (Tool) for showing why this forum is so helpful.

Dibs
X 2 for that.

Post Reply