fed up trying to get her to run properly, 12a elford

Rotary Engine Chat......Got A Problem With Your Rotary Engine.... Need Help...?
codge
Posts: 2554
Joined: Fri Apr 01, 2011 11:41 am
Location: South Yorks.

Re: fed up trying to get her to run properly, 12a elford

Post by codge » Sun Apr 09, 2017 11:48 pm

Reminds me of my first car, an Austin 10 around 1963. It had stood for months.
I similarly tried everything I could read up on.....and would it start.....Nope. No chance.

Then it was towed by a couple of neighbours across a bit of waste land back of our house. Blimey, it came back under it's own power.

Yeh, it started again over the next few days. Seems the cobwebs had to be blown out of it!

User avatar
DKWW2000
Posts: 1161
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: fed up trying to get her to run properly, 12a elford

Post by DKWW2000 » Mon Apr 10, 2017 3:44 pm

Great news - Make sure you let it warm up slowly & do not rev up until the thermostat has opened up & she is on normal, they hate short runs before warm etc. Was there any smoke (white/blue)? Have you tried starting since?
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

User avatar
Hobbawobba
Posts: 1230
Joined: Tue Nov 01, 2011 9:44 pm
Location: Worcester - UK

Re: fed up trying to get her to run properly, 12a elford

Post by Hobbawobba » Mon Apr 10, 2017 4:54 pm

Wooo! Good to hear. Mine was acting up recently after not starting for a while. A mile down the road it cleared up nicely and has been sweet since. Give it a few good redlines when you've been driving a bit and it's nicely warmed up :D

As Pete just asked.. Have you tried to start her again? How'd it go if you did? :mrgreen:

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Mon Apr 10, 2017 7:02 pm

no smoke at all. cant rag it down the road got to run it in properly, havent tried to start it again yet, working away. i need to put some miles on the engine to build up compression.

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Tue Apr 11, 2017 8:31 pm

on the key, it could be a good summer, cheers all

Post Reply