fed up trying to get her to run properly, 12a elford

Rotary Engine Chat......Got A Problem With Your Rotary Engine.... Need Help...?
rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Tue Feb 14, 2017 7:10 pm

got my self a smoke machine of ebay [ halloween syle] so i will smoke it up this weekend to see if it is the dreaded vac leak. if it is then its turbo off. [was easy out the car] if not i will give kev's carb man a bell {the carb had no isues before the engine rebuild ? ] summers cumin so i will get my finger out, and not buy any more projects that take my time away from my long term love affair with my elford, owned her 18 years nearly. hope all is well with your car kev ? and ian thanks for the imput

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Sun Feb 19, 2017 10:21 am

yes its the dreaded vac leak. started to take off the inlet manifold, looks like the exhaust manifold will have to come off. to get to all the bolts, [ 2 have studs and nuts in a recess,so you cant put a socket on them ] did not torque these two up last time. think i need a special nut about 25mm long to clear the recess to get a socket on [ proberly the problem] now need a exhaust manifold gasket, any idea of part number?

User avatar
ian65
Posts: 5609
Joined: Wed Mar 30, 2011 12:11 am

Re: fed up trying to get her to run properly, 12a elford

Post by ian65 » Sun Feb 19, 2017 7:38 pm

this is the exhaust manifold gasket that you need.....

http://www.rockauto.com/en/catalog/mazd ... asket,5400

http://www.rockauto.com/en/moreinfo.php ... 50&jsn=442

other styles of gasket won't block off the emissions ports and you'll get a blow.

dirt cheap from RockAuto but postage knocks it up... still cheaper than buying one in the UK though, especially if you can team up with someone else on here who wants something and split the shipping

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Mon Feb 20, 2017 7:34 pm

thanks for that lord elford, gives me a good excuse to order some other goodies as well

KiwiDave
Posts: 1762
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: fed up trying to get her to run properly, 12a elford

Post by KiwiDave » Tue Feb 21, 2017 1:56 am

rip7 wrote: Lord Elford
W(p W(p W(p W(p W(p W(p W(p
1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Wed Feb 22, 2017 7:27 pm

got the exhaust manifold and inlet manifold off today WHAT A PIG OF A JOB . exhaust manifold gasket looks ok , might re use it? . inlet manifold has a small cavity [ indent] in it, should i fill it [ plastic pading ]? also should i do away with the o rings and fit plugs. dont ever want to take that lot off again EVER,

User avatar
ian65
Posts: 5609
Joined: Wed Mar 30, 2011 12:11 am

Re: fed up trying to get her to run properly, 12a elford

Post by ian65 » Wed Feb 22, 2017 8:46 pm

it's a real sod of a job :D :D
You can reuse the exhaust the exhaust gasket... clean it thoroughly with brake cleaner then put a very thin smear of exhaust paste on each side before bolting it back up..... use some proper stuff that comes in a cartridge to go into a mastic gun, not that crap Holts GunGum rubbish that turns to dust and falls out. A proper motor factors should have the proper stuff.
You can fill any imperfections in the manifold mating surface with Araldite or JB Weld and sand it down. Use a genuine Mazda inlet gasket... they're only about a tenner from a Mazda dealer.
Definitely lose the O rings and bang a couple of 20mm stainless coreplugs in...

you can see the parts I used to put mine back together here...

http://www.rx7fb.com/viewtopic.php?f=4&t=2174&start=150

although the last time I pulled my turbo off I reused the manifold gasket and put exhaust paste on it.

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Mon Feb 27, 2017 7:47 pm

got my inlet manifold gasket, tried the inlet manifold back on but it dont cover the open block port under the tall ports on the centre iron [ vac leak ?] am i missing something? lord elford words of wisdom.

User avatar
MelloYello
Posts: 1087
Joined: Wed Jun 01, 2011 8:42 pm
Location: London, England.

Re: fed up trying to get her to run properly, 12a elford

Post by MelloYello » Mon Feb 27, 2017 8:01 pm

Photos please

rip7
Posts: 133
Joined: Thu Aug 18, 2011 8:37 pm
Location: essex

Re: fed up trying to get her to run properly, 12a elford

Post by rip7 » Tue Feb 28, 2017 9:54 am

the elford inlet manifold does not fully cover the EGR port, should it be blanked of ? [ tried to post pictures] have i lost something ?

Post Reply