KIMI 2 - 1983 Series 2

Restoring or fettling your ride ? Show us your progress.
User avatar
DKWW2000
Posts: 1179
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: KIMI 2 - 1983 Series 2

Post by DKWW2000 » Thu Nov 16, 2017 5:22 pm

Well done Malcolm, always feels good when you got a new ticket.......I would suggest you buy a scratch/lotto ticket quick as you seem to be on a roll (Blue well done emoji)
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

User avatar
Casey
Posts: 426
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: KIMI 2 - 1983 Series 2

Post by Casey » Thu Nov 16, 2017 5:28 pm

LOL - not a bad idea Pete :-)

However, I'm feeling quite chuffed at the moment, so I'm just waiting for something negative to happen to even things out ;-) :-)
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
A7RXY
Posts: 1115
Joined: Fri Apr 01, 2011 6:55 am
Location: Upminster, Essex UK

Re: KIMI 2 - 1983 Series 2

Post by A7RXY » Thu Nov 16, 2017 7:39 pm

Well done two results in two days, now for the hartrick .....

Dibs

KiwiDave
Posts: 1751
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: KIMI 2 - 1983 Series 2

Post by KiwiDave » Thu Nov 16, 2017 11:21 pm

Casey wrote:MOT passed with no advisories!
Even after all these years, the exhaust manifold apparently come off without a fight for the welding work on the flange.

Yippee!!
KIMI 2 has a charmed life indeed. Our cars are not known for being overly co operative in the parts submission department (or at least mine isn't). Well done you
1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

User avatar
Casey
Posts: 426
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: KIMI 2 - 1983 Series 2

Post by Casey » Sat Apr 21, 2018 4:58 pm

Nothing much to report, but as I haven't posted on here for a while.....

Recently, during KIMI 2's first "proper" drive after her winter lay up, I did experience a vibration from the rear when travelling over ~45mph.

it was such a lovely day here today that I took KIMI 2 out for a 20 mile run and topped up with fuel. Sunroof up and windows down, I really enjoyed it 8-)

Before I went out though, I checked all the fluid levels (OK) and checked the tyre pressures, to discover they were down to a (very even!) ~17psi all round :oops: I pumped them up to the recommended 26psi and didn't detect any vibration this time out :)

Hopefully, that's all that was causing the problem :oops:

Looking forward to some more of this weather to enjoy further outings 8-)
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
Casey
Posts: 426
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: KIMI 2 - 1983 Series 2

Post by Casey » Fri Apr 27, 2018 2:52 pm

Gratuitous pics of my two "on the road" rotaries :)

Image

Image


I have now put KIMI 2 in the garage and removed the rear hatch for some remedial work to the paint around the hatch area. Not sure how good the finish is going to be with rattle cans, but the paint is bubbling up in a good few places, so can't be worse than seeing that get worse.

I will also see if I can get the struts re-gassed at SGS Engineering, plus refurbish the hinges and other bit's and bobs on the hatch:


Image

I'll also try to do something with this:


Image

Does anyone know what the original colour of the logo was? I know someone with a vinyl cutter who might be able to knock something up.

Lastly, silly question probably, but I assume OEM hatch lock should open with door lock key? Mine has never worked - either wrong key, or seized solid inside the mechanism. I left is soaking in WD-40 for a day and still solid.

Image
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
Casey
Posts: 426
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: KIMI 2 - 1983 Series 2

Post by Casey » Fri Apr 27, 2018 2:53 pm

Something wrong with the forum today :?

Can only get first photo to display in any post I put up.....despite the "preview showing all is OK :? :?
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
Casey
Posts: 426
Joined: Sat May 07, 2011 5:46 pm
Location: Colchester, UK

Re: KIMI 2 - 1983 Series 2

Post by Casey » Fri Apr 27, 2018 3:07 pm

Weird, I've redone the post above but hosting pics on Flickr and inserting links instead.

Anyone can help with the lock and logo questions?
KIMI 1 : RX-7 1st Gen "hybrid"; 1983 S2 running gear in a 1985 S3 shell, SORN'd, long term resto project
KIMI 2 : RX-7 1st Gen; 1983 S2, "identical" twin to KIMI 1, on the road :-)
Plus a 2004 Full Bridgeported RX-8 too!

User avatar
DKWW2000
Posts: 1179
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: KIMI 2 - 1983 Series 2

Post by DKWW2000 » Fri Apr 27, 2018 3:14 pm

I think the original Logo was red..............but might be wrong!
All photos seem to be fine with me Malcolm.
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

User avatar
A7RXY
Posts: 1115
Joined: Fri Apr 01, 2011 6:55 am
Location: Upminster, Essex UK

Re: KIMI 2 - 1983 Series 2

Post by A7RXY » Fri Apr 27, 2018 3:59 pm

My logo is similar to your photo dark grey on black and I'm sure that is original.

Post Reply