Why does my rad fan fuse keep blowing?

Fans, radiators, heaters, e-fans, cooling issues, air conditioning...
KiwiDave
Posts: 1789
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: Retro Rides Gathering - 23rd August 2015 - Shelsley Wals

Post by KiwiDave » Tue Aug 18, 2015 1:31 am

Doh! Just read the other post. So it's high pitched and constantly on. I'd say it's the 'headlights on' buzzer.

If it was me, I'd be locating the buzzer unit and disabling the thing for now. That's the easy fix if time is short.

As a very left field suggestion, do you have anything plugged into your lighter socket? And does the buzzer stop if you unplug said item?
1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

User avatar
DKWW2000
Posts: 1210
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: Retro Rides Gathering - 23rd August 2015 - Shelsley Wals

Post by DKWW2000 » Tue Aug 18, 2015 1:15 pm

Where have you taken the positive feeds from?
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

apexheid

Re: Retro Rides Gathering - 23rd August 2015 - Shelsley Wals

Post by apexheid » Tue Aug 18, 2015 1:41 pm

switch off the hearing aids and that'll be quite as a graveyard.... :D

KiwiDave
Posts: 1789
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: Why does my rad fan fuse keep blowing?

Post by KiwiDave » Wed Aug 19, 2015 2:01 am

The constantly sounding buzzer issue may have nothing to do with your recent rewiring.

Check your 'Oscillator' relay. It's mounted in front of the battery close to the left side headlamp and is marked Oscillator. :roll: The horn relay is also mounted close by.

I had the same issue as yours, found a thread on RX7.com , replaced said relay and all was quiet

I believe you can just unplug it and achieve the same result. There should be plenty of wrecked FB's with that relay still intact.

Either that or disconnect the buzzer unit and forget it!
1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

KiwiDave
Posts: 1789
Joined: Sat Nov 05, 2011 8:07 pm
Location: Feltham, Southwest London

Re: Why does my rad fan fuse keep blowing?

Post by KiwiDave » Wed Aug 19, 2015 2:42 am

1985 Sunrise Red S3 TWR
2003 Mercedes E320 CDI Estate AMG

Lucky
Posts: 2686
Joined: Mon Nov 07, 2011 8:30 pm
Location: Worthing, UK

Re: Why does my rad fan fuse keep blowing?

Post by Lucky » Sat Aug 22, 2015 1:14 pm

Well... that was weird :?

First up, from the symptoms Dave described I think he diagnosed the issue spot on; it was the oscillator relay. The buzz was a constant high-pitched whine, not the intermittent bleep of the coolant buzzer. In my defence, I've never heard the coolant buzzer on an FB, only on the FD where it is a constant high-pitched whine, just to confuse things. So I jumped ahead, added two and two and got eleventy million :oops:

Secondly, it definitely wasn't anything to do with my re-wiring because I used the exact same points of origin as the original wiring, only re-made it not shit. And it didn't do this before.

Thirdly, before we went away to the monster-in-law's I mentioned that maybe the elves would take a night off from fixing shoes for old cobblers and sort my car out, but they probably won't because elves are all lazy feckless bxxxxxxs nowadays with no proper work ethic. Well, it appears I owe the elves an apology because I got back last night, went out to try and sort the problem today... and it's magically fixed itself :shock: Going out for a test drive shortly but it looks like for now I might be back in the game :twisted:


Weird stuff is weird. Still, if anyone has a good oscillator relay they can flog me? It might relieve some of the paranoia of driving along waiting for it to go mutant again :(

User avatar
DKWW2000
Posts: 1210
Joined: Sun Jul 06, 2014 10:16 pm
Location: English Riviera - South Devon

Re: Why does my rad fan fuse keep blowing?

Post by DKWW2000 » Sat Aug 22, 2015 1:42 pm

Glad to hear all well, must have been fixed by RRG God who has also sorted the weather for tomorrow W(p
RX7 FB S3 - RX7 FC TII Vert
Rotaries Previously Owned:-
2 x NSU Ro 80s - 2 x S2 RX7s - Suzuki RE 5 - DKW(Hercules) W2000 - Norton (Krauser) Commander

User avatar
ian65
Posts: 5653
Joined: Wed Mar 30, 2011 12:11 am

Re: Why does my rad fan fuse keep blowing?

Post by ian65 » Sat Aug 22, 2015 1:48 pm

I've got a box full of FB relays..... I'll chuck them in the car for tomorrow and you can help yourself to whichever one you need.
1986 Series 3 13B Turbo II
http://rx7fb.com/viewtopic.php?f=2&t=2400
1992 Peugeot 205 1.9 GTI
1975 Honda SL125 Street Scrambler

Lucky
Posts: 2686
Joined: Mon Nov 07, 2011 8:30 pm
Location: Worthing, UK

Re: Why does my rad fan fuse keep blowing?

Post by Lucky » Sat Aug 22, 2015 2:22 pm

Thanks, Ian, much appreciated h:

Test drive cautiously looks promising. No bleeping at least!

Might need to get a slightly higher off-temperature sensor switch as once the fan's on it can't get the temperature down past the switch-off trigger point... seems to be pre-set at under 80 degrees! So it kinda stays on. However, it holds the temperature at under 90 even when queuing; a lot more manly than the 14" Kenlowe

Post Reply