Temp gauge stopped working

Anything related to the cars electrics... problems.... mods... fixes etc
Post Reply
daily rotor
Posts: 57
Joined: Sun Oct 25, 2015 1:16 am

Temp gauge stopped working

Post by daily rotor » Sun Feb 07, 2016 7:40 am

Hi guys my temperature gauge on my dashboard has just stopped working. Clock,fuel,revs and speed gauges all still work..
im definitely not having any overheating issues, but would like to rectify it before that ever becomes a reality.
It has a temp gauge wired into the top of the radiator, wiring looks ok.
My guess is that i will need to replace that temp gauge on top of radiator.
any more experienced guys that would look elsewhere first?
suggestions appreciated thank you

P.s its an old series 2 with a stock 13b.

User avatar
spirit r
Posts: 1323
Joined: Sat Feb 09, 2013 4:15 pm
Location: Germany Black Forest
Contact:

Re: Temp gauge stopped working

Post by spirit r » Sun Feb 07, 2016 7:49 am

It is the levelswitch for the warning buzzer not the temperature gauge you checked.
You will find the temperature gauge under the oilfilter. Good luck!

daily rotor
Posts: 57
Joined: Sun Oct 25, 2015 1:16 am

Re: Temp gauge stopped working

Post by daily rotor » Sun Feb 07, 2016 8:23 am

thanks man, c that is why i ask here!!
i automatically assumed it was the gadget sticking out the top of the radiator :?
going to suss it out now.

daily rotor
Posts: 57
Joined: Sun Oct 25, 2015 1:16 am

Re: Temp gauge stopped working

Post by daily rotor » Sun Feb 07, 2016 8:34 am

yes excellent work Sherlock (Spirit R)
geez it helps when u look in the right place.
wiring has clean snapped off, looks an easy repair even for a dumb ass like me.
probably happenned when i done 8,000rpm 1st to 2nd gear changes i keep telling myself not to do :)
i can relax again

daily rotor
Posts: 57
Joined: Sun Oct 25, 2015 1:16 am

Re: Temp gauge stopped working

Post by daily rotor » Sun Feb 07, 2016 8:41 am

so to educate myself further while the opportunity exists
that contraption in the top of radiator will sound an alarm if it gets too hot?
i fear i may have a broken an engine mount as well.
because one of the dizzy capacitators wiring seperated itself too (at least it done it at the connectors) and was easily plugged back in.
damn im really going to have to stop changing gears like that.
there is paint scrapped of the underside of bonnet too.

User avatar
ian65
Posts: 5548
Joined: Wed Mar 30, 2011 12:11 am

Re: Temp gauge stopped working

Post by ian65 » Sun Feb 07, 2016 10:37 am

there are 3 sensors in total related to the cooling system. The one on top of the rad is coolant level.... if the level drops too low in the radiator it should illuminate a red light on the dash and also a warning chime.
The temperature gauge sender is the one that Thomas directed you to under the oil pressure switch.
There is a 3rd sensor on the water pump housing just by the thermostat housing.... this one sender a signal to the choke system to let it know when to switch off once the engine warms up.

daily rotor
Posts: 57
Joined: Sun Oct 25, 2015 1:16 am

Re: Temp gauge stopped working

Post by daily rotor » Sun Feb 07, 2016 11:34 am

Thanks Ian65 & Thomas (Spirit R) s(c)

Post Reply